How to install package in old laravel project

I have a project built in laravel 5.8 and I want to add socialite package in this project but whenever I try to install the socialite package it gave me this error all the time. enter image description here Here is my composer.json

{
"name": "laravel/laravel",
"type": "project",
"description": "The Laravel Framework.",
"keywords": [
"framework",
"laravel"
],
"license": "MIT",
"require": {
"php": "^7.1.3",
"anandsiddharth/laravel-paytm-wallet": "^1.0",
"anhskohbo/no-captcha": "^3.1",
"barryvdh/laravel-dompdf": "^0.8.6",
"caouecs/laravel-lang": "~4.0",
"cartalyst/stripe-laravel": "10.*",
"doctrine/dbal": "^2.10",
"fideloper/proxy": "^4.0",
"guzzlehttp/guzzle": "~6.0",
"instamojo/instamojo-php": "^0.4.0",
"laravel/framework": "5.8.*",
"laravel/socialite": "^5.0",
"laravel/tinker": "^1.0",
"masterro/laravel-xss-filter": "^1.0",
"mollie/laravel-mollie": "2.0",
"paypal/rest-api-sdk-php": "^1.14",
"phpmailer/phpmailer": "^6.1",
"rachidlaasri/laravel-installer": "^4.1",
"razorpay/razorpay": "2.*",
"renatomarinho/laravel-page-speed": "^1.8",
"softon/indipay": "^1.2",
"spatie/laravel-cookie-consent": "^2.10",
"spatie/laravel-sitemap": "^5.7",
"willvincent/feeds": "^2.1"
},
"require-dev": {
"beyondcode/laravel-dump-server": "^1.0",
"filp/whoops": "^2.0",
"fzaninotto/faker": "^1.4",
"mockery/mockery": "^1.0",
"nunomaduro/collision": "^3.0",
"phpunit/phpunit": "^7.5"
},
"config": {
"optimize-autoloader": true,
"preferred-install": "dist",
"sort-packages": true
},
"extra": {
"laravel": {
"dont-discover": []
}
},
"autoload": {
"psr-4": {
"App\": "app/"
},
"classmap": [
"database/seeds",
"database/factories"
],
"files": ["app/Http/Helpers/Helper.php"]
},
"autoload-dev": {
"psr-4": {
"Tests\": "tests/"
}
},
"minimum-stability": "dev",
"prefer-stable": true,
"scripts": {
"post-autoload-dump": [
"Illuminate\Foundation\ComposerScripts::postAutoloadDump",
"@php artisan package:discover --ansi"
],
"post-root-package-install": [
"@php -r "file_exists('.env') || copy('.env.example', '.env');""
],
"post-create-project-cmd": [
"@php artisan key:generate --ansi"
]
}

Note: I am using PHP Version 7.4 with laragon
Please help me to solve this problem.
Thanks in Advance

from Newest questions tagged laravel-5 – Stack Overflow https://ift.tt/2TsXYe6
via IFTTT

Related Posts

Codeigniter : Parse error: syntax error, unexpected ‘const’ (T_CONST), expecting variable (T_VARIABLE) in Laravel project

I’m getting following error: **Parse error: syntax error, unexpected ‘const’ (T_CONST), expecting variable (T_VARIABLE)** Note : It’s working in local but facing issue in production server. private…

Firebase receive notification while tab is active or on focus

What i want is to be able to perform an action when a user receives a notification while the browser is open and tab is active or…

Laravel’s alias loader does not find class

We have a legacy project that we cannot update and we need to make some changes in symfony’s Response.php in vendor. We have solved this by copying…

Laravel 5 – generic document management

I have a system where you can create different types of unique documents. For instance, one document is called Project Identified and this expects certain inputs. Originally,…

Laravel Nova limit the results in indexQuery

I ran intro a situation where I need to limit the results of a resource to only 3 results. To be more specific, based on the logged…

Auditoria en laravel 5.8 [closed]

Cómo puedo automatizar el registro de actividades de un usuario en laravel? Si un usuario ingresa a un app de laravel, debo guardar toda su actividas, a…

Leave a Reply

Your email address will not be published.